Update
Following hate, the Transport Parody Accounts of Twitter have decided to stop monitoring the parody accounts, we all hope to be back at some point.
Posted Dec 07, 2023 - 14:42 UTC
Identified
Following hate, the Transport Parody Accounts of Twitter have decided to stop monitoring the parody accounts, we all hope to be back at some point.
Posted Oct 30, 2023 - 17:56 UTC
This incident affects: Avanti Late Coast, Crap2Customers, Chiltern Failways, Cross-Chaos, East Midlands Failway, Elizabeth Line, Gatwick Distress, Grand Cancel, Not So Great Northern, Late Western Railway, Later Anglia, Heathrow Depress, Hell Trains, LNER, London Northwestern Failway, Northern Fail, South Western Failway, Southeastern Failway, Southern Fail, TransPennine Distress, Chaos For Wales Rail, Lumno Fail, ThamesShite, West Midlands Failway, and Haggis Rail.